Thoughts please

The EtherTen combines an Uno-equivalent Arduino-compatible board and Wiznet-based Ethernet support, along with a microSD card slot and Power-over-Ethernet support. [Product page]
Post Reply
AHarre
Posts: 1
Joined: Wed Sep 19, 2018 2:00 am

Thoughts please

Post by AHarre » Wed Sep 19, 2018 2:21 am

Hi folks.

I am new to arduino and am really only trying to get some help and thoughts.

Here is what I am trying to do.
I have about a dozen solar powered up cameras dotted around the place communicating via 3/4G gprs routers. The cameras and routers are powered by 250 watt solar panels and 2x30 amp hour batteries. What i am trying to do is monitor the status of the batteries and output and communicate that via ftp or some other way to a pc so we can keep an eye on things.
There is as far as I can tell no commercially avaible product for anything under a 60 ish amp solar array. So I thought I would see if I could build my own.

What I've done so far.
I purchased an etherten with the reasoning that it already has a built in network and sdcard and this would simplify the end product. I also got a acs712 current meter to start with. I copied the supplied code into the etherten but was getting strange reading with amps in the negative 1.8 range without anything connected to It. I though that maybe I needed to run the etherten of a 12 volt supply but as soon as I plugged that in I let the smoke out of the current sensor and the etherten started getting warm.

What I'd like to know.
Is it even possible to get current and voltage sent to a server? It doesn't sound too hard.
What did I do wrong with the current sensor?
Has this been done before? I can't find anything anywhere online.
It certainly sounds to me like a fairly simple thing but maybe I'm wrong.
That has been known to happen.

Thanks in advance.

Post Reply