USBDroid not being detected by Android phone

The USBDroid provides USB Host functionality for use as an Android peripheral as an Open Android Development Kit board. [Product page]
Post Reply
Freezerohmatic
Posts: 5
Joined: Fri Jun 10, 2016 5:22 am
Location: Sydney Australia

USBDroid not being detected by Android phone

Post by Freezerohmatic » Fri Jun 10, 2016 5:33 am

Hi All,

I've resently starting trying to ge the USBDroid to act like an android accessory and I have had minimal success. Less then 5% of the time the phone responce to the board and behaves properly. I have tried with 3 different devices all of them show similar results.

The success rate does increase with a higher charge phone.

I am using the USB Host 2.0 example code, devices are a Sony Z1 (very low success, basically no response), Sony xperia table Z (board thinks its connected but table does not respond, only tested at 50% power) and a low end huawei (can't remember the model number, only at +95% battery, phone sees the board 50% of them time).

I would appreciate any help.

Freeze

Freezerohmatic
Posts: 5
Joined: Fri Jun 10, 2016 5:22 am
Location: Sydney Australia

Re: USBDroid not being detected by Android phone

Post by Freezerohmatic » Wed Jun 15, 2016 3:42 pm

Found the issue.

It seems the pins on the VBus shunt had been bent slightly in, causing the voltage to drop just below 4.6 V.

Bent them back out and sitting at a nice 4.85 V.

Having another issue with USBHost 2.0 ADK implementation but that has been submitted to the GIt
link: https://github.com/felis/USB_Host_Shield_2.0/issues/245

Post Reply