One single LED not working

The "Cube4" is a 4x4x4 RGB LED cube with an Arduino Leonardo compatible onboard controller. [Product page]
Post Reply
Joined:Wed Dec 28, 2016 6:28 pm
One single LED not working

Post by emiskilla03 » Wed Dec 28, 2016 7:05 pm

Before even attempting assembling and soldering the cube4 I tested every single LED to make sure they each worked and could light up red, green, and blue. Once I verified that every LED was working I began assembling and soldering. Once everything was finished, I plugged in the cube4 to my MacBook and it began the testPattern sketch. Here is a video of the result. Instead of the LED lighting up (233) the LED that's three below it (on the very bottom panel- 230) lights green and then the correct LEDs light up as they should. I also notice another LED that lights a slight green when 233 should be on during the testPattern sketch- 013. The LEDs xyz position is 233. The solder joints on the LED looks ok, and the other connections also look ok. Where should I begin in diagnosing this problem? Last resort is to desolder this LED and replace it. Thanks in advance for any help!

Joined:Sat Dec 31, 2016 9:01 am

Re: One single LED not working

Post by JoelD » Sat Dec 31, 2016 9:13 am

Funny i just went through this today. Being quite amateur about it i had desoldered the thing and put it together and even replaced two of the LEDs, i started putting it together piece by piece after that. After each layer of PCB i would test it through the test pattern. Most of the time it just had to do with the actual joints, even though they look fine it doesnt take much to have a half a joint on an led still making a fuss.

One thing i did was even though the colours weren't all connected exactly right ( when all white you have a few strange colours) i waited for the test pattern to finish and then i used the Arduino IDE's serial monitor tool to type in a command " all white; " this would then light them all white and i would begin diagnosing. ... mmand-list

What i was told about LEDs is that they never lie. Its always going to be either the solder, joint or polarity. Probably not the right thing to do but while in the white mode i tweaked the ones that didnt work with my solder iron which would disrupt the polarity on the joint to show me where the issue was. Basically id move the soldering iron ( just tapping not melting the solder) on each of the joints on the led if that didnt help i would move to the bigger solder joints on the pcb, this was quite a quick way to do it and i wish i had done that prior to pulling it apart. Now it works great.

hope this helps


Post Reply