No leostick driver but sketch running

A shrunk down Leonardo-compatible board, thumb drive sized with native USB support. [Product info]
Post Reply
frank
Posts: 3
Joined: Sat Feb 16, 2013 12:16 pm

No leostick driver but sketch running

Post by frank » Sat Feb 16, 2013 12:30 pm

I followed all the instructions on the freetronics site when I first got my Leostick and
it worked.

I installed the sample blink program, Ok

Then I put it away.

Somewhere along the line I rebuilt my PC.

Then I tried to use my leostick again but had trouble because The driver is not installed.
And the stick came up as
"Arduino Leonardo"
deviceInstance ID = USB\VID_2341&PID_0034&MI_00\...... etc

Windows doesnt recognise "FreetronicsUSB_V10.inf"

But I searched around and found in the following folder
C:\download12\Arduino\arduino-1.0.3-windows\arduino-1.0.3\drivers\Arduino Leonardo.inf
Which is where I extracted the arduino software

I opened it using wordpad
and added a third device to the [DeviceList]

[DeviceList]
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_0036
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_8036&MI_00
%DESCRIPTION%=DriverInstall, USB\VID_2341&PID_0034&MI_00


Then ran device manager again and updated the driver pointing to this new file.
The device immediately became visible. and available in Arduino 1.0.3

I am now able to compile and load sketches again directly to the leostick.
I dont know what I will do if the sketch freezes as mentioned for a locked up sketch.
Because I havent figured out how to install the usb driver for the boot loader section
that is recognised as ="Freetronics LeoStick"

I'm guessing it wont be there long enough to use the driver update function in device manager.
Any suggestions on how to load a driver for a device that isn't there?
For when this event does occur.

Post Reply