Older Ethermega hangs on sketch upload

Combining the power of the ATmega2560 MCU with onboard Ethernet, a microSD card slot, an efficient switchmode power supply, and a small prototyping area. [Product page]
Post Reply
Posts: 1
Joined: Wed Jul 20, 2016 11:06 pm

Older Ethermega hangs on sketch upload

Post by bazinoz » Wed Jul 20, 2016 11:18 pm

Older Ethermega HANGS on sketch upload

I have a few older Ethermega's out in the field where I send updated sketches as hex files uploaded with Xloader.

In the past things have worked fine but my latest version will not upload, it starts and then just hangs. After some time Xloader displays the message "Upload failed".
I can upload older versions fine. They are both 491Kb in size.

I then tried to do it direct using Visual Studio and I get "The uploader returned an error".

Then the Arduino IDE.....
Sketch uses 178,608 bytes (70%) of program storage space. Maximum is 253,952 bytes.
Global variables use 5,839 bytes (71%) of dynamic memory, leaving 2,353 bytes for local variables. Maximum is 8,192 bytes.
avrdude: ser_open(): can't open device "\\.\COM199": The system cannot find the file specified.
avrdude: ser_drain(): read error: The handle is invalid.
Problem uploading to board.

This problem does not occur with the current Ethermega's.

Does anyone know what is going on?


Post Reply