Search found 853 matches

by angusgr
Tue Jun 21, 2016 5:41 am
Forum: Raspberry Pi Expansion Boards
Topic: RPi3
Replies: 18
Views: 19521

Re: RPi3

Hi folks,

It looks like we may have had some bad boards slip through QA. If you're using the latest software and your PiLeven still doesn't respond, please email support@freetronics.com and let us know what you've tried.

We'll get everyone up and running (with new hardware if necessary) ASAP.

Angus
by angusgr
Tue Jun 21, 2016 12:15 am
Forum: Eleven
Topic: Serial monitor
Replies: 5
Views: 6431

Re: Serial monitor

Can you post a photo of the setup you have, please? LEDs are polarised, meaning they only work one way. The long lead of the LED has to point towards the "positive" side (usually towards the Arduino pin), and the short lead towards the "negative" (towards ground). If the LED is backwards then it won...
by angusgr
Mon Jun 20, 2016 7:57 am
Forum: Eleven
Topic: Serial monitor
Replies: 5
Views: 6431

Re: Serial monitor

Hi hotdogink,

What happens if you open one of the example sketches in the Arduino IDE (for example, go to File -> Examples -> Basic -> Blink) and then press the "Upload" button in the IDE (shaped like an arrow), to send it to your Eleven?

Angus
by angusgr
Mon Jun 20, 2016 7:55 am
Forum: HBRIDGE: H-Bridge Motor Driver Shield
Topic: Uncoordinated Movements with Stepper Motor
Replies: 3
Views: 8323

Re: Uncoordinated Movements with Stepper Motor

Hi xtoph, Sorry for the frustrating experience wiring up the motor. It sounds like you're very close to having it working, though. Usually movements like what you're describing are caused by wiring problems with the coils. The links you posed to the australianrobotics site for the motor aren't worki...
by angusgr
Mon Jun 20, 2016 7:48 am
Forum: EtherTen
Topic: Upload error ten with POE
Replies: 1
Views: 4558

Re: Upload error ten with POE

Hi Stylmast, The errors like this: avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd5 Suggest that it's a problem with the USB connection to the board, not the code in your sketch. Maybe double-check the COM port chosen is correct, ...
by angusgr
Mon Jun 20, 2016 7:46 am
Forum: EtherTen
Topic: USB driver problem
Replies: 7
Views: 7065

Re: USB driver problem

Hi Scot, All 3 of these boards should be running identical USB/serial interface firmware, so from that point of view they should all appear as the same device. Is it possible there's another factor involved - choice of USB cable, choice of USB port, position of onboard power selection jumper, etc.? ...
by angusgr
Mon Jun 20, 2016 7:43 am
Forum: Experimenters Kit
Topic: Freetronic atmega328p
Replies: 2
Views: 19441

Re: Freetronic atmega328p

Hi T6000, It sounds like it might be something with your setup if two chips in a row don't work. Can you please post a photo of your flashing setup? Also if you go to Preferences in Arduino and turn on "Verbose" for Uploading, can you please copy-paste the output you get when running "Burn Bootloade...
by angusgr
Mon Jun 20, 2016 7:42 am
Forum: Module Discussion
Topic: USBasp dead?
Replies: 3
Views: 6760

Re: USBasp dead?

Sorry for the slow reply, Graeme. Looks like it is indeed not seeing the USBAsp at all.

It could be a driver issue in Windows. If you open the Device Manager control panel while the USBasp is unplugged and then plug it in, do any new entries appear?

Angus
by angusgr
Thu May 26, 2016 6:29 am
Forum: Raspberry Pi Expansion Boards
Topic: RPi3
Replies: 18
Views: 19521

Re: RPi3

Hi folks, Sorry for the delay. The new Raspbian release helped me out as well. The pileven-installer.sh script is now updated for Raspberry Pi 3 on the latest Raspbian (should work with older Raspbian as well, but we recommend this month's release.) See the full details on the Getting Started page: ...
by angusgr
Thu May 26, 2016 2:09 am
Forum: Module Discussion
Topic: USBasp dead?
Replies: 3
Views: 6760

Re: USBasp dead?

When you say the IDE doesn't see it, what exactly do you mean? The USBasp is a bit unusual, because it doesn't appear in the "Ports" list in the Arduino IDE tools menu (as it's not actually a USB serial port, it's a different kind of USB device.) However, if you choose USBAsp for programmer type und...